Changes between Version 1 and Version 2 of COP3402Spring2011/InstallEclipseCpp


Ignore:
Timestamp:
08/31/11 13:39:49 (11 years ago)
Author:
steven.zittrower
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • COP3402Spring2011/InstallEclipseCpp

    v1 v2  
    1 = Installing Eclipse for C/C++ =
    2 [[PageOutline]]
     1= Installing Eclipse for C/C++ =  [[PageOutline]]
    32
    43These are some step-by-step instructions on how to setup Eclipse for compiling C/C++ programs. If you prefer to use Visual Studio or any other IDE, you can simply ignore them :-) .
     
    109Under Windows, you have to install the GNU development tools, but fortunately there is an Eclipse extension called "Wascana" that takes care of that. See below for detailed instructions on how to acquire it. If you develop under Linux or MacOS, just skip the instructions on installing "Wascana".
    1110
    12 If you already have Eclipse for Java installed and want to add the C/C++ functionality, please start reading [#IfyoualreadyhaveEclipseforJavainstalled here].
    13 If you prefer a new Eclipse installation, start reading [#IfyouprefertoinstallaseparateEclipse here].
     11If you already have Eclipse for Java installed and want to add the C/C++ functionality, please start reading [#IfyoualreadyhaveEclipseforJavainstalled here]. If you prefer a new Eclipse installation, start reading [#IfyouprefertoinstallaseparateEclipse here].
    1412
    1513If you encounter any problems, please send me an e-mail ( rpillat@knights.ucf.edu ) or see me during my office hours.
    1614
    1715== If you already have Eclipse for Java installed ==
    18   - If Eclipse is installed somewhere in your user folder, simply launch the executable. Otherwise, make sure to right-click the executable and select "''Run as administrator''" (you will need write access to the Eclipse folder to install the new plugins).
     16 * If Eclipse is installed somewhere in your user folder, simply launch the executable. Otherwise, make sure to right-click the executable and select "''Run as administrator''" (you will need write access to the Eclipse folder to install the new plugins).
    1917
    20  - Once the workspace opens, select "Help -> Install new software"
    21  - A new window opens. In the "Work with:" combobox, select the "Helios" repository.
    22  - There will be a list of available packages. You are only interested in the "Programming Languages -> C/C++ Development Tools" software. Select the checkbox in front of it
     18 * Once the workspace opens, select "Help -> Install new software"
     19 * A new window opens. In the "Work with:" combobox, select the "Helios" repository.
     20 * There will be a list of available packages. You are only interested in the "Programming Languages -> C/C++ Development Tools" software. Select the checkbox in front of it
    2321
    24    [[Image(eclipse_cdt_install.png)]]
     22  [[Image(eclipse_cdt_install.png)]]
    2523
    26  - Now hit the "Next" button, accept the license terms and click "Finish".
    27  - Eclipse will ask you to restart, so please do so.
     24 * Now hit the "Next" button, accept the license terms and click "Finish".
     25 * Eclipse will ask you to restart, so please do so.
    2826
    29  - Now we have to install one more package. Once the workspace opens, select "Help -> Install new software" (for the second time ;-) )
    30  - In the upper-right corner click the "Add" button.
    31  - In the new "Add repository" window, enter "Wascana" under "Name" and "http://svn.codespot.com/a/eclipselabs.org/wascana/repo" under "Location". Click the OK button.
    32    
    33    [[Image(wascana_install.png)]]
     27 * Now we have to install one more package. Once the workspace opens, select "Help -> Install new software" (for the second time ;-) )
     28 * In the upper-right corner click the "Add" button.
     29 * In the new "Add repository" window, enter "Wascana" under "Name" and "http://svn.codespot.com/a/eclipselabs.org/wascana/repo" under "Location". Click the OK button.
    3430
    35  - Eclipse will now add "Wascana C/C++ Developer for Windows" to the list of available software. Mark the checkbox in front of that.
     31  [[Image(wascana_install.png)]]
    3632
    37    [[Image(wascana_install_2.png)]]
     33 * Eclipse will now add "Wascana C/C++ Developer for Windows" to the list of available software. Mark the checkbox in front of that.
    3834
    39  - Now hit the "Next" button twice, accept the license terms and click "Finish".
    40  - Eclipse will ask you to restart, so please do so.
     35  [[Image(wascana_install_2.png)]]
    4136
    42  - Read on if you want to know how to [#CreatinganewCCproject create a new C/C++ project]
     37 * Now hit the "Next" button twice, accept the license terms and click "Finish".
     38 * Eclipse will ask you to restart, so please do so.
     39
     40 * Read on if you want to know how to [#CreatinganewCCproject create a new C/C++ project]
    4341
    4442== If you prefer a new Eclipse installation ==
    45  - Download "Eclipse IDE for C/C++ Developers" from http://www.eclipse.org/downloads/
    46  - Unzip the archive somewhere in your user folder.
    47  - Start Eclipse.
     43 * Download "Eclipse IDE for C/C++ Developers" from http://www.eclipse.org/downloads/
     44 * Unzip the archive somewhere in your user folder.
     45 * Start Eclipse.
    4846
    49  - Once the workspace opens, select "Help -> Install new software"
    50  - A new window opens. In the upper-right corner click the "Add" button.
    51  - In the new "Add repository" window, enter "Wascana" under "Name" and "http://svn.codespot.com/a/eclipselabs.org/wascana/repo" under "Location". Click the OK button.
     47 * Once the workspace opens, select "Help -> Install new software"
     48 * A new window opens. In the upper-right corner click the "Add" button.
     49 * In the new "Add repository" window, enter "Wascana" under "Name" and "http://svn.codespot.com/a/eclipselabs.org/wascana/repo" under "Location". Click the OK button.
    5250
    53    [[Image(wascana_install.png)]]
     51  [[Image(wascana_install.png)]]
    5452
    55  - Eclipse will now add "Wascana C/C++ Developer for Windows" to the list of available software. Mark the checkbox in front of that.
     53 * Eclipse will now add "Wascana C/C++ Developer for Windows" to the list of available software. Mark the checkbox in front of that.
    5654
    57    [[Image(wascana_install_2.png)]]
     55  [[Image(wascana_install_2.png)]]
    5856
    59  - Now hit the "Next" button twice, accept the license terms and click "Finish".
    60  - Eclipse will ask you to restart, so please do so.
     57 * Now hit the "Next" button twice, accept the license terms and click "Finish".
     58 * Eclipse will ask you to restart, so please do so.
    6159
    62  - Read on if you want to know how to [#CreatinganewCCproject create a new C/C++ project]
     60 * Read on if you want to know how to [#CreatinganewCCproject create a new C/C++ project]
     61
     62== Compilers: MinGW vs. Wascana ==
     63 * Wascana is no longer supported, while it can still be installed and used the developers recommend using MinGW for Windows based systems. Detailed instructions on installing this compiler can be found here. [http://max.berger.name/howto/cdt/ar01s03.jsp Setting Up a Compiler].
     64 * Linux/Unix should come with a built in compiler. You can check if it is installed by running the command `g++ --version and make --version`
     65 * Mac OS X may or may not have a compiler installed on it already. You can try the above command to see if the Gnu compiler is installed. If no you'll need to install the developer tools. Instructions for this can be found at the above link.
     66
     67
     68
     69
    6370
    6471== Creating a new C/C++ project ==
    65  - From the menu select "File -> New -> C++ Project" (or "C Project" if you prefer). If these options don't show up, try to find them under "File -> New -> Other -> C/C++".
    66    A wizard for a new project will open. Enter an appropriate name and select "Hello World C++ project".
     72 * From the menu select "File -> New -> C++ Project" (or "C Project" if you prefer). If these options don't show up, try to find them under "File -> New -> Other -> C/C++". A wizard for a new project will open. Enter an appropriate name and select "Hello World C++ project".
    6773
    68    [[Image(new_cpp_project.png)]]
     74  [[Image(new_cpp_project.png)]]
    6975
    70  - Click "Finish" and you are the proud author of a C++ HelloWorld project. It's a simple project that only prints out a greeting to the console when you run it.
     76 * Click "Finish" and you are the proud author of a C++ HelloWorld project. It's a simple project that only prints out a greeting to the console when you run it.
    7177
    72  - To build the project click the hammer symbol, to run it the play button, and to debug it the little bug.
     78 * To build the project click the hammer symbol, to run it the play button, and to debug it the little bug.
    7379
    74    [[Image(build_debug_run.png)]]
     80  [[Image(build_debug_run.png)]]